OVH versions PHP obsolètes

Aller en bas

OVH versions PHP obsolètes

Message  Annie le Sam 4 Juil 2015 - 19:50

Je pense que nous sommes nombreux à être hébergés chez OVH. Avez-vous reçu leur mail disant que l'on doit tester nos sites etc...

je n'ai rien compris etude

si quelqu'un peut m'expliquer sachant que perso, mon site fait avec Publisher est transcrit automatiquement en html... sans doute comme les autres sites faits avec des logiciels ne nécessitant pas de codage...

Merci

Annie
avatar
Annie

Messages : 1554
Date d'inscription : 08/09/2010
Localisation : Lorraine, Meuse

Voir le profil de l'utilisateur http://www.ruedeschamps.fr

Revenir en haut Aller en bas

Re: OVH versions PHP obsolètes

Message  Marie Odile le Lun 6 Juil 2015 - 22:34

J'ai reçu ce mail aussi mais ne me suis pas encore penchée sur le problème.

Marie Odile
avatar
Marie Odile

Messages : 1750
Date d'inscription : 21/11/2010
Age : 63
Localisation : Alsace, Haut-Rhin, Orschwihr 68500

Voir le profil de l'utilisateur http://gite-alsace-vignoble.com

Revenir en haut Aller en bas

Re: OVH versions PHP obsolètes

Message  Gilbert le Mar 7 Juil 2015 - 1:56

J'ai aussi bien sûr reçu cet email.

Ce message d'OVH concerne le langage PHP qui est utilisé, en complément du langage HTML, dans l'écriture des pages de nos sites.
Dans mon site par exemple, seul le formulaire de réservation, le planning de réservation affiché et un diaporama font appel à un petit module écrit en langage PHP.
Le code PHP de la page est exécuté par le serveur qui héberge le site (donc les serveurs d'OVH) et non pas par le PC de l'internaute, comme l'est le code HTML. Par exemple, c'est lui qui s'occupe de l'envoi vers ma boite mail de l'email contenant les données saisies par le client sur la page du formulaire de réservation.
A l'époque où ces pages ont été réalisés, le code PHP utilisé était la version courante proposée par OVH sur ses serveurs mais comme le PHP évolue de nouvelles version de ce langage viennent remplacer les anciennes. Le souci c'est que la compatibilité ascendant du code n'est malheureusement pas toujours garantie dans ces évolutions de langage.

Ce qu'OVH nous dit, c'est qu'il ne garanti pas que le code utilisé pour écrire nos pages il y a quelques années en langage PHP fonctionne toujours dans le futur et qu'on pourrait être obligé de modifier ce code PHP pour le ré-ecrire dans une variante plus récente de ce langage pour que ça fonctionne toujours sur leurs nouveaux serveurs.
Comme ce n'est pas évident de savoir à l'avance si cette évolution des serveurs d'OVH va ou non poser problème pour son usage dans votre site (ça dépend du fait que vous utilisez ou non le langage PHP dans vos sites et aussi des instructions PHP que vous avez utilisées), vous pouvez toujours à l'échéance donnée par OVH faire un test fonctionnel complet du site pour voir si vous rencontrez ou non un problème.

A noter:
- l'utilisation du langage PHP dans vos sites peut être vu par la présence d'au moins un fichier dont l'extension est .php dans la liste des fichiers présents sur l'hébergement de votre site chez OVH (dans le répertoire www). S'il n'y en a pas, vous n'êtes pas concerné par cette évolution d'OVH. De nombreux sites n'utilisent pas le PHP mais uniquement des langages exécutés sur le navigateur PC des internautes (html, javascript, ...).
- de nombreux outils de création de site (WordPress par exemple, mais bien d'autres) utilisent le PHP. Il peut être nécessaire de réaliser une mise a jour de l'outil s'il date un peu. Avec ToWeb, c'est apparemment le cas si vous utilisez les i-services.

Gilbert

_________________
Une visite sur mes sites internet: http://www.gite-en-alsace.net et http://www.un-gite-en-alsace.fr
Une visite sur L'annuaire des gîtes et chambres d'hôtes d'alsace: http://www.gite-en-alsace.net/annuaire.html
Une visite sur l'annuaire "Nos Gîtes et nos Chambres d'hôtes": http://www.nos-gites-et-nos-chambres-dhotes.fr
avatar
Gilbert
Admin

Messages : 2934
Date d'inscription : 16/08/2010
Age : 68
Localisation : MUTZIG, ALSACE, FRANCE

Voir le profil de l'utilisateur http://www.gite-en-alsace.net

Revenir en haut Aller en bas

Re: OVH versions PHP obsolètes

Message  Marie Odile le Mar 7 Juil 2015 - 2:57

Merci beaucoup Gilbert pour ces explications. Je vais vérifier si j'ai des extensions php.

Marie Odile
avatar
Marie Odile

Messages : 1750
Date d'inscription : 21/11/2010
Age : 63
Localisation : Alsace, Haut-Rhin, Orschwihr 68500

Voir le profil de l'utilisateur http://gite-alsace-vignoble.com

Revenir en haut Aller en bas

Re: OVH versions PHP obsolètes

Message  Annie le Mar 7 Juil 2015 - 7:33

Merci Gilbert... je vais également vérifier...

Annie
avatar
Annie

Messages : 1554
Date d'inscription : 08/09/2010
Localisation : Lorraine, Meuse

Voir le profil de l'utilisateur http://www.ruedeschamps.fr

Revenir en haut Aller en bas

Re: OVH versions PHP obsolètes

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum